Symptom
Error "Sales support block is set for party ID XXXXXX with role Account in master data" for transactional documents such as Leads, Opportunities, Activities when created from Account.
Environment
SAP Cloud For Customer
Reproducing the Issue
- Go to Customer Workcenter.
- Open Accounts Workcenter view.
- Go to Leads/Opportunities/Activities facet
- Click on New button.
- Enter the Sales Organisation from Sales Data maintained in the Account.
Error: "Sales support block is set for party ID XXXXXX with role Account in master data".
Here XXXXXX is the Account ID.
You even notice that the Sales Support Block flag is unchecked both at Header level and Sales Data level, but you still see the Error while creating new transactional documents.
Cause
You have maintained Cross-Account Sales Data blocks in Workcenter Business Partner -> Common Tasks -> Maintain Cross-Account Sales Data.
Resolution
The Error message will not be seen once these blocks are removed.
Keywords
sales support block, lead, opportunity, activity, common tasks, Maintain Cross-Account Sales Data. , KBA , LOD-CRM-ACC , Account , LOD-LE-RC-PAP , Party Processing , Problem