Symptom
Some of the Header Data of Contact is not Fetched for All Accounts
Environment
SAP Cloud for Customer
Reproducing the Issue
1. Go to Customers Workcenter.
2. Go to Contacts Workcenter view.
3. Open any Contact.
5. Go to Relationship Facet.
6. Open the Business Partner.
7. Go to Contacts Facet.
The details of contact such as department, mobile and function are not seen
Cause
For a contact person relationship there are 2 main flags:
1. Main checkbox in the list of Relationship facet.
2.''Main Account'' in the details of each line item.
The first ''Main'' checkbox if checked represents that the Contact is the main Contact of the Account. The second one represents which Account is the main Account of the Contact.
In order to update the header information of the Contact, you need to flag the ''Main Account'' of the details.
The header data of the contact (function, dept, job title etc) is only for the main account.
Resolution
This is the expected system behaviour.
Keywords
contact, main, relationship, , KBA , LOD-CRM-CON , Contact , Problem