Symptom
Error message is shown in HIRE UIs "The HRIS element is disabled or has no fields enabled. Please contact your system administrator for support."
When "Enable Centralized Services to Add New Employee, Add New Employee for Fixed Term, and Rehire Inactive Employee" is enabled via Company System and Logo Settings.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental
Environment
SAP SuccessFactors Employee Central
Reproducing the Issue
- Ensure "Enable Centralized Services to Add New Employee, Add New Employee for Fixed Term, and Rehire Inactive Employee" is enabled via Company System and Logo Settings.
- Add a New Employee through a Hire UI
- On the final submit an error is shown:
"The HRIS element is disabled or has no fields enabled. Please contact your system administrator for support." - This may only be shown for some users in the system or some hires, not all.
Cause
This error is occurring when the instance has a configuration issue where a Global Information Entity is configured but does not have any enabled Fields.
For example gobalInfo_AUS is enabled but there are no fields configured or they are ALL set to Enabled = No:
This is not supported:
- At least one field has to be enabled with visibility View or Editable.
- If you do not wish to use Global Information for this country then the Global Information Country should be disabled. In this case, please ensure that you do not have active employees assigned to that country on Global Information.
- More information on what fields should be enabled for each element can be found in the following KBA:
2586311 - Manage Business Configuration: Which hris-elements must be enabled and configured for Employee Central
Resolution
To resolve the issue:
- At least one field has to be enabled with visibility View or Editable. For the list of fields for each country please review the guide:
Country/Region-Specifics for Employee Central - If you do not wish to use Global Information for this country then the Global Information Country should be disabled.
- Navigate to Manage Business Configuration
- Expand globalInfo
- Review each country and ensure:
- At least one field has to be enabled with visibility View or Editable.
OR - The element is disabled if you not wish to use it and if you don't have employees assigned to it.
- At least one field has to be enabled with visibility View or Editable.
- Save the changes
See Also
Keywords
KI2311, CS2H2023, The HRIS element is disabled or has no fields enabled. Please contact your system administrator for support, ECT-214694, CS20230006402273, INC6355493, add new employee, new hire, submit hire , KBA , LOD-SF-EC-HIR , Hire & Rehire Wizards , Problem