Symptom
When creating a new customer contract, you find the Item ID is not editable. The first Item ID is always 10. While in the sales order, you are able to edit and change Item Line ID when creating.
Environment
SAP Business ByDesign
Reproducing the Issue
Customer Contract.
- Go to the Sales Orders work center.
- Go to the Contracts view.
- Create a new contract and fill mandatory fields in the General tab.
- Go to Items tab, click Add Row, the first row added, Item ID defaults to 10 and you are not able to change it.
Sales Order.
- Go to the Sales Orders work center.
- Create a new sales order and fill mandatory fields in the General tab.
- Go to the Items tab, Click Add Row, the first row added and it defaults to 10. The item Line ID is editable, you can change it to another value.
Cause
Item ID in the contract is not editable.
Resolution
This is the current designed behavior.
Keywords
Contract; Item ID. , KBA , SRD-CRM-INV , Customer Invoicing , Problem
Product
SAP Business ByDesign 2308 ; SAP Business ByDesign 2311