SAP Knowledge Base Article - Public

3392790 - Employee names displaying as alpha-numeric codes in Global Search

Symptom

After performing an instance refresh, alphanumeric codes are displayed instead of employee names when searching in the Target instance.

Sample screenshot when you search the employee name. Here's how it looks like. 

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental." 

Environment

SAP SuccessFactors HCM Suite

Reproducing the Issue

  1. Log into the Target instance after the Instance Refresh.
  2. Use the search bar to look up any user.
  3. Notice the search results appear as alphanumeric codes rather than employee names.

Cause

There are two potential causes for this issue:

📍 Cause 1:
The "Enable Name Format" feature is activated in the Target instance.

📌 Cause 2:
The "Enable Adoption of General Display Name" feature is turned on in the Target instance.
If Data Anonymization was performed during the Instance Refresh, the "DISPLAYNAME" field for all users would be anonymized, leading to this issue.

  • Instance Refresh Data Anonymization Fields
    • "Display Name" field type of anonymization is Deterministic Anonymization.
    • Deterministic Anonymization, in this type of anonymization, the actual value is replaced with any alpha-numeric value in the target instance.

Resolution

📍 For Cause 1:
The "Enable Name Format" feature can be disabled via Provisioning.

📌 For Cause 2:
The "Enable Adoption of General Display Name" feature can be disabled in the "Company System and Logo Settings" page.

Keywords

search bar, code, number and characters, alphanumeric, instance refresh, provisioning , KBA , LOD-SF-PLT-SRH , Search , Problem

Product

SAP SuccessFactors HCM Suite all versions

Attachments

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