SAP Knowledge Base Article - Public

3392835 - Additional Enrollment Field not showing during benefit enrollment - Employee Central

Symptom

The additional fields configured for a benefit is not showing during enrollment or claim. 

Environment

SAP SuccessFactors Employee Central

Cause

There are a few possible reasons, but mostly this is a configuration or sync issue. 

Resolution

Make sure to check the below:

  • The additional field association was configured correctly as per KBA 2731317;
  • You have a Screen ID (it can be a standard or a customized UI) defined for this benefit;
  • After configuring custom objects either in Benefit Enrollment or Benefit Employee Claim, it's important to resave the defined UI once the Additional Enrollment Field is updated in the Benefit configuration. This can be done with a dummy change, for example.

See Also

Defining Enrollment Details
2731317 - Custom object not displayed in Proof Details or Additional Claim Fields drop down while creating a benefit 
2749373 - Getting errors "Duplicate Period Duration found for Benefit Company Car Enrollment" when using Additional Enrollment Fields "BenefitCompanyCarEnrollment" when enrolling for a benefit. 

Keywords

Additional Enrollment Field, custom field, enrollment UI, employee claim UI, Additional Claim Fields , KBA , LOD-SF-EC-GBF , Global Benefits , Problem

Product

SAP SuccessFactors Employee Central all versions ; SAP SuccessFactors HCM Suite all versions