Symptom
- Custom email trigger after New Hire Data Review step completion is not getting triggered.
- Custom email template is not triggering to the recipient.
Environment
SAP SuccessFactors Onboarding
Cause
Configuration Issue:
- There was a problem in the email category, as a result, the email template is getting skipped.
- An incorrect content builder or recipient builder was used in the custom trigger resulting to the email notification getting skipped.
Sample Error from the Logs:
- Failed to construct email message for trigger: <Email Template Name> : <Instance ID> | <Custom Trigger Name> completed for activityId: <Candidate Process ID>. Skipping the template.
Resolution
As per the Implementation Guide, you must configure the email category with the appropriate content builder and recipient builder.
For example, if the Data Source configured in the business rule is Process Task, then you must select an appropriate Content Builder and Recipient Builder for this data source.
- Appropriate Content Builder for Process Task:
- Onboarding Nudge assignee content builder
- Onboarding Process Task Content Builder
- Appropriate Recipient Builder for Process Task:
- Onboarding Process Task Role-Based Recipient Builder
- Dynamic Group Recipient builder
- Explicit Recipient Builder
- Onboarding User ID Recipient Builder
See Guidelines for Setting Up Business Rules to Trigger Email Notifications
See Also
Keywords
Custom Email Trigger, Custom email NHDR Step, Email Services, Emails, NHDR, New Hire Data Review step email, Email not triggered, Content Builder, Recipient Builder, Custom Email Template, OBX, EML, ONB, ONB2, Onboarding , KBA , LOD-SF-OBX-EML , Notifications , Problem