SAP Knowledge Base Article - Public

3393768 - Incident Description in Service Quote Changes When Using the Create with Reference Functionality

Symptom

Incident Description in a Service Quote is removed or changes when creating it as a reference of a Service Request.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to the Service Orders work center.
  2. Select the Service Quotes view
  3. Open Service Quote ABC (ABC represents the ID of the Service Quote).
  4. Navigate to the General tab and the Main Information sub tab.
  5. In the Incident Description you can see the following text:
    Incident Description in the Service Quote you want to copy
  6.  Click on the Copy button.
  7. In the New Service Quote you can see in Incident Description you can see the following text copied from the Service Quote ABC:
    Incident Description in the Service Quote you want to copy
  8. Click on the button Create with Reference.
  9. Select Reference Type: Service Request and Reference ID:  XYZ (XYZ represents the ID of the Service Request).
  10. Click on OK.
  11. You can see that in the Incident Description the copied text from Service Quote ABC is removed and the text from the Incident Description of Service Request XYZ is determined by the system.

Cause

When you create a Service Quote as a reference of a Service Request the Incident Description is taken over from the Service Request the same way it would if as if you create a Service Quote using the Follow-Up functionality in the Service Request. If there is no text in the Incident Description of the Service Request, then the Incident Description of the Service Quote created as a reference will also have no Incident Description.

Resolution

This is the expected system behaviour.

Keywords

Incident Description; removed; cleared; changed; Follow-Up; Create with Reference; Service Quote;  , KBA , AP-CQP-CQ , Customer Quote , Problem

Product

SAP Business ByDesign 2308 ; SAP Business ByDesign 2311 ; SAP Business ByDesign 2402