Symptom
It is not possible to update an user assigned to business role ABC with the settings of this role.
Environment
SAP Business Bydesign
Reproducing the Issue
- Open the business role ABC
- Navigate to the tab Assigned Business Users
- Select Update Users
- The assigned business user remains In Progress and does not have the role settings. The associated update run might be shown as Completed after a while, but without Result, and no Application Log is available
Cause
The business user is not only assigned to business role ABC, but also to business role XYZ which is obsolete and causing inconsistencies.
(ABC and XYZ represent business roles).
Resolution
- Go to Application and User Management
- Go to Business Users
- Choose the user ABC
- Choose Edit - Access Rights
- De-assign business role XYZ from the business user
- repeat the access rights update of role ABC.
Keywords
Missing; does not work; stuck; remains In Progress; no Application Log; access rights , KBA , SRD-CC-IAM , Identity & Access Management , Problem
Product
SAP Cloud for Customer core applications all versions