SAP Knowledge Base Article - Public

3394524 - Access Rights Of The Business User Has Been Deleted By Technical User (SAP_SYSTEM) Automatically

Symptom

Workcenter assignment for the Business User: ABC has been deleted by Technical User 'SAP_SYSTEM'.

Environment

SAP Business ByDesign

SAP Cloud For Customer

Reproducing the Issue

1. Go to Administrator workcenter
2. Select Business User view
3. Search for the Business User: ABC and select Edit Access Rights
4. Navigate to Changes Tab

Now, you can find the access rights are deleted by Technical User SAP_SYSTEM in the change log.

Cause

The user authorizations had to be updated manually in Workcenter Administrator -> Business Users -> Action: “Update Access Rights”. Therefore an automated update of the user's access rights has been introduced via backend batch job.

The job is running hourly which is implemented by the following BO types:
    •    Organizational Unit
    •    Business Partner Relationships
    •    Territory

Resolution

This is the standard system behavior. The background jobs are executed by the technical user SAP_SYSTEM, modifications to the following assignment results in the deletion of the workcenter. The employee’s authorizations are adapted automatically in case of any relevant change for the below objects, for example:. This includes adding, removing the access to workcenters. As backend jobs run with technical users, these are listed as trigger for such changes. 

  • Employee org assignment changes or is finished,
  • Account team assignment has changed,
  • Territory team assignment has changed,
  • etc.

Keywords

Access Rights, SAP_SYSTEM, Technical User(SAP_SYSTEM), Changes, User Changes, User Access Rights, Business User , KBA , SRD-CC-IAM , Identity & Access Management , Problem

Product

SAP Business ByDesign all versions ; SAP Cloud for Customer core applications all versions