Symptom
Ticket History Data Source not showing the specific people who worked on a Ticket in the field Changed By. Instead it shows a _ODATA User
Environment
SAP Cloud for Customer
Cause
By default the standard Data Source Ticket History does not show the full list of users who made changes to a Ticket. It shows only the last change made to the Ticket. Enhancing the standard report is considered as a new Requirement and must be followed up via SAP Influence Page.
Resolution
The full users change history can be found under the Changes facet within the Ticket UI itself. Another option is to extract this data via Odata https://blogs.sap.com/2023/03/01/export-business-object-change-logs-history-from-sap-cloud-for-customer-c4c/
Keywords
Missing; Wrong User; Historical; , KBA , LOD-CRM-SRP , Service Request Processing , How To