SAP Knowledge Base Article - Public

3394603 - When importing an Integration Definition in Integration Center nothing happens - HXM Suite

Symptom

When trying to upload an integration definition (.icd file) in Integration Center, the file is selected successfully but nothing happens on the screen, no error, no reload, and the integration definition doesn't pull up.

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

  • SAP SuccessFactors HXM Suite
  • SAP SuccessFactors Recruiting Management

Reproducing the Issue

  1. Log into the instance
  2. Go to Integration Center
  3. From Create button, click on Import an Integration Definition
  4. Select the file and click on Upload
  5. Nothing happens when trying to upload the .icd file

Cause

This is happening because the user doesn't have the "Intelligent Services Center (ISC)" permission, and the file requires access to the Intelligent Services Center page.

This can be seen from the Network logs in the Developer Tools, in the action of uploading the file:

Resolution

In order to grant this permission, the steps are as following:

  1. Go to Admin Center
  2. Navigate to Manage Permission Roles, and select the role you wish to modify
  3. Click on Permissions
  4. Scroll down to Intelligent Services Tools
  5. Tick the checkbox for  "Intelligent Services Center (ISC)"

See Also

2212494 - Enabling Intelligent Services feature on SuccessFactors and accessing Intelligent Services Center

2209164 - How to enable integration Center in SuccessFactors System? - SAP SucessFactors HXM Suite

Keywords

intelligent, services, event, center, centre, integration, icd, file, definition, screen, blank, reload, stuck. , KBA , LOD-SF-RCM-INT , Integration Center & Intelligent Services , LOD-SF-INT-INC , Integration Center , Problem

Product

SAP SuccessFactors HCM Suite all versions ; SAP SuccessFactors Recruiting all versions