Symptom
When trying to upload an integration definition (.icd file) in Integration Center, the file is selected successfully but nothing happens on the screen, no error, no reload, and the integration definition doesn't pull up.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
- SAP SuccessFactors HCM Suite
- SAP SuccessFactors Recruiting Management
Reproducing the Issue
- Log into the instance
- Go to Integration Center
- From Create button, click on Import an Integration Definition
- Select the file and click on Upload
- Nothing happens when trying to upload the .icd file
Cause
This is happening because the user doesn't have the "Intelligent Services Center (ISC)" permission, and the file requires access to the Intelligent Services Center page.
This can be seen from the Network logs in the Developer Tools, in the action of uploading the file:
Resolution
In order to grant this permission, the steps are as following:
- Go to Admin Center
- Navigate to Manage Permission Roles, and select the role you wish to modify
- Click on Permissions
- Scroll down to Intelligent Services Tools
- Tick the checkbox for "Intelligent Services Center (ISC)"
See Also
Keywords
intelligent, services, event, center, centre, integration, icd, file, definition, screen, blank, reload, stuck. , KBA , LOD-SF-RCM-INT , Integration Center & Intelligent Services , LOD-SF-INT-INC , Integration Center , Problem
Product
Attachments
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