Symptom
When searching for a Partner in the Sales Order header (Partner tab), the system displays the message:
"No values found"
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- Open the Change Sales Orders – VA02 app.
- Find and open the required Sales Order using the value help.
- Click Continue.
- In the Change Standard Order screen, go to the header section and click on Display header details.
- Navigate to the Partner tab.
- For the Partner Function: Employee Responsible, click on the value help in the Partner field.
- System throws the error: "No values found."
Cause
The Business User does not have the required Business Catalog SAP_SD_BC_CUST360_DISPL_PC assigned to their Business Role.
Resolution
- Assign the Business Catalog SAP_SD_BC_CUST360_DISPL_PC to the Business User using the Maintain Business User app.
- Once assigned, the Employee Responsible partners will be visible in the value help.
Keywords
SAP S/4HANA Cloud Public Edition, Public Cloud, Sales Order Header, SAP_SD_BC_CUST360_DISPL_PC, Partner, Partner Search Issue, Sales Order, SAP_SD_BC_CUST_SLSOVP_DSP_PC, Maintain Business User, SAP_BCR_SD_CUST_SLSOVP_DSP_PC, Employee Responsible, Partner Functions, No Values Found, Change Standard Order, Business Catalog Missing , KBA , SD-SLS-SO , Sales Orders , Problem