SAP Knowledge Base Article - Public

3396424 - Preview button does not work for Billing documents - S/4HANA Cloud

Symptom

When reviewing billing documents using app 'Manage Billing Documents', the preview function doesn't work for some documents and returns with error message: "No Preview Available".

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."

Environment

SAP S/4HANA Cloud

Reproducing the Issue

  1. Go to Manage Billing Documents app
  2. Select billing document
  3. Click on 'Preview'
  4. Error message appears:

Cause

The system does not generate preview because there are no available output items for the Billing Document.

Resolution

In order to see the preview for the document, please maintain entries at the "Output Items" tab and generate a valid output item (Printout (PRINT), Email (EMAIL), etc.).

Therefore the system will be able to shows the required document when clicking on 'Preview' button.

In case you would like your system to automatically add output items to your documents, please maintain your configurations following Guided Answers - Output Management in SAP S/4HANA Cloud -> Configuration points.

See Also

SAP Fiori Apps Library - Manage Billing Documents

SAP Help - Editing Output Items

Guided Answers - Output Management in SAP S/4HANA Cloud -> Configuration points

Keywords

manage billing documents, output, preview, print, invoice, output item, output type, No Preview Available , KBA , SD-BIL-GF-OC-2CL , Output Control Billing (Public Cloud) , CA-GTF-OC , SAP S/4HANA output management , Problem

Product

SAP S/4HANA Cloud 2308