Symptom
Managers or HRs are receiving the following error message while trying to restart the I-9: ONBOARDING2_REINITIATE_FORM_I9_SECTION_I9_DIALOG_CORRECT_SECTION1_FAILURE_MSG
Reason for this issue: This issue appears to be with the Receipt Flow Only: because a Receipt of a Document has been provided, Onboarding is not permitting the user to Restart (via the new Button) the Old Form I-9 and throws above error. There is an issue with the code for this use case which potentially existed before new I9 form.
"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."
Environment
SAP SuccessFactors Onboarding
Cause
This is a known issue.
Resolution
Permanent fix- There is a code correction (OBX-28667) and engineering is targeting a patch for 9th November.
Workaround:
- Go to Admin Center > Manage data
- For the affected record, set the "I-9 User Data" object to the status "I-9 Section 1 Signed" or "I-9 Section 2 Saved"
- then I9 can be restarted
Keywords
Restart, onb, i-9, i9, obd, onboarding, ONBOARDING2_REINITIATE_FORM_I9_SECTION_I9_DIALOG_CORRECT_SECTION1_FAILURE_MSG, error, OBX-28667 , KBA , LOD-SF-OBX-I9 , i9 Compliance Form , Known Error