Symptom
- Using check tool to show orphan account data and removal of this orphan record.
- Incorrect Assignment username mapping
- Missing Login Account data
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors HCM Suite
Reproducing the Issue
- Empty login name field for users, users cannot be found in manage login accounts
- IPS sync failed with error [ error=com.sap.security.iag.provisioning.mapping.exceptions.InvalidJsonContentException: Source path: $.personKeyNav.userAccountNav.username is not available in content, but is required in defined system transformation Caused by: com.sap.security.iag.provisioning.mapping.MandatorySourcePathNotFoundException: Source path: $.personKeyNav.userAccountNav.username is not available in content, but is required in defined system transformation Caused by: com.jayway.jsonpath.PathNotFoundException: Expected to find an object with property ['username'] in path $['personKeyNav']['userAccountNav'] but found 'null'. This is not a json object according to the JsonProvider: 'com.jayway.jsonpath.spi.json.JsonSmartJsonProvider ]
- Go to Employee Export;
- Confirm that User and their Username exists in System and UDF
- Go to Data Inspector
- Query Table Table_USER_ACCOUNT
- Query on Username field with your user username
- No data in User Account DB Table found for those users
Cause
- With SF continuous development, there are some legacy dirty data in SF system which leads to issues.
- import sequence is not respected when adding new users (correct sequence to follow is as per help guide Employee Data Import Process | SAP Help Portal )
Resolution
Orphan account check tool
To fix any legacy dirty data in SF system and to keep our system more clear, Product team has innovated a check tool to show orphan account in check tool and deal with this kind of cases.
In current release, customer admin now can use the check tool to run this check in the system health, so that they can know whether there are orphan accounts in system and quick fix can be run to fix the issue.
If system has orphan accounts, when customer admin run the check, will show the orphan accounts with account id, login name, person id and when click quick fix, then the check tool will purge the orphan accounts and show success.
If system has no orphan then customer will see no issue founds.
Account data missing fix tool
As a customer admin, now you can use the check tool to fix account data missing issue in system health for below issue scenario , so that they can know which data are impacted and the expected fix result.
Pre-requisites -> Kindly run first the check tool to check the "Primary assignment" should be correct for each person. (IncorrectPrimaryAssignmentCheckExecutor)" to primary assignment information.
https://me.sap.com/notes/0003259486
Which kind of data can be fix:
- Person with one assignment
- Person with multiple assignments (GA/CE case)
- Go to Data Inspector
- Query Table Table_USER_ACCOUNT
- Query on Username field with your user username;
- No data in User Account DB Table found for those users
Account data missing fix tool will resolve below issue usecases
UC 1: Given a tenant with account data missing, when there is person with one active assignment, the expected login name should be the assignment username.
UC 2: Given a tenant with account data missing, when there is person with one inactive assignment, the expected login name should be the assignment username.
UC 3: Given a tenant with account data missing, when there is person with both active assignments, the expected login name should be the primary assignment username.
UC 4: Given a tenant with account data missing, when there is person with both inactive assignments, the expected login name should be the primary assignment username.
UC 5: Given a tenant with account data missing, when there is person with both active and inactive assignments, the expected login name should be the primary assignment username and account type should be calculated.
As a customer admin, can use quick fix, so that data issues are fixed.
Quick fix:
The check tool will search all persons with employments but without account use case. You can use the check tool to create a relevant account in order to resource some data issue.
You can use “Quick Fix” to fix account data in your system.
See Also
Keywords