Symptom
Using the app Replicate by Object Selection, you are replicating the Business Partners to the SAP Central Invoice Management system. Upon executing the replication, the system throws the error:
Error while processing the SOAP request. Please check the Generic Configuration again.
Environment
SAP S/4HANA Cloud
Reproducing the Issue
- Go to the app Replicate by Object Selection
- Business Object Type: Business Partner including Relationships
- Partner: XXXXXX
- Target System Selection: System ID: XYZ
- Select the entry and click on the button Replicate
- System processes the replication, but in the Message Monitoring app, BP_OUT generated error message.
where XXXXXX represents the Business Partner ID
XYZ represents the Target System
Cause
Missing configuration.
Resolution
- Configure the Business System Name and enable SOAP replication on MDI, that is, maintain the Generic Configuration. In the documentation for Setting Up Invoice Processing with SAP Central Invoice Management, refer the section Maintain Configuration to maintain the configuration through an API call. If maintaining the configuration through the API call does not work, maintain the same via UI instead of API.
- Check if the SenderBusinessSystemID is same as the Business System ID configured in the Service instance.
- Ensure that RecipientBusinessSystemID should be same as the Business System ID configured in Generic Configuration.
See Also
Setting Up Invoice Processing with SAP Central Invoice Management
Prerequisites - Business System Configuration
Keywords
SenderBusinessSystemID, RecipientBusinessSystemID, Business System ID, Replication, . Please ch eck the Generic Configuration again, Business System is not configured in Generic Configuration, Business Partner, Communication Arrangement, SAP_COM_0008 , KBA , LO-MD-BP , Business Partners , Problem