SAP Knowledge Base Article - Public

3397461 - Multi-Customer Solution (MCS) Lifecycle management actions: Request Template, Qualification Review before Deployment and Installation Key renewal

Symptom

  • You want to develop a Multi-Customer Solution (MCS) add-on using SAP Cloud Applications Studio (CAS) and do not know either how to request a MCS or how to generate the installation key in the CAS, as this feature is not activated.
  • Furthermore, your existing authorization to deploy your MCS into the customer tenant have expired (typically it lasts for one year) and you need to qualify your MCS again to deploy the add-on on your customer tenant.

Environment

  • SAP Cloud Applications Studio
  • SAP Business ByDesign

Cause

The partner development system does not allow the user to create an MCS or perform deployment actions into customer productive tenants and facilitate its maintenance in several customers.

Resolution

  • MCS Creation Request Template

To request a Multi-Customer Solution (MCS) template for your ByD development tenant, please raise an incident from the tenant using the description MCS Template Creation in ByD Dev Tenant and provide the following information in the main body of the incident request:

  1. Partner Development System Details (Tenant ID, SID/Client):  
  2. Partner Details: Partner-CRM-ID: 
  3. Description / MCS Name (up to 60 characters):
  4. Detailed Description of MCS (up to 255 characters):
  5. Deployment unit in ByD (where partner wants to create the MCS Solution. Ex: Foundation, Purchasing, …): 
  6. Name and e-mail address of the main contact person:  

       

      Please note that each MCS template request needs to be submitted individually in an incident request.

      Please be aware that once this incident is closed and you have been provided with the MCS template in your tenant, this will need to go through a Quality Review. After this review you will be able to deploy your MCS solution in the customer tenant by generating the installation key as requested in CAS.

      If you need assistance creating an incident, please visit the SAP for ME.

       

      • Quality Review

      To request a Quality Review (QR) of your Multi customer Solution (MCS), please raise an incident from the tenant using the description MCS Quality Review in ByD Dev Tenant and provide the following information in the main body of the incident request:

      • Solution Description: - e.g: Activation of Installation Key Generation for MCS
      • Solution Name: “Solution Name
      • MCS Technical ID: “Technical Name of MCS” (alpha numeric key)
      • Partner ID: “Partner ID
      • Tenant URL: “Dev Tenant URL

      Component:  AP-RC-BDS-MCS-REQ.

      Once the Quality Review in your MCS is completed, you will be able to deploy your MCS in customer tenant after installation key is generated by SAP.

      Qualification Review approval is applied in your Development Tenant. In the case, other developers team member does not get the confirmation, please check regularly in your tenant as your MCS may be already certified.

      • Installation Key renewal (MCS lifecycle management)

      Please note, a MCS Quality Review is only valid for a period of one year or until the solution undergoes any version update, whichever is earlier. If you need to extend a Quality Review, please raise another incident with above details.

      Keywords

      Multiple, Customer, Solution, Lifecycle, management, Actions; Qualification, Review, before, deployment, Installation, Key, renewal , KBA , AP-RC-BDS-MCS-REQ , Request for Multi-Customer Solution , AP-RC-BDS-MCS , Multi-Customer Solution , How To

      Product

      SAP Business ByDesign all versions ; SAP Cloud Applications Studio all versions