Symptom
Time of visit appointment in route template cannot be changed.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Navigate to Visits Work Center.
- Go to Routes.
- Search and open the Route Template "XXXXXX", where XXXXXX is the route template ID.
- Visits in this Route Template for example are scheduled from 8AM to 3PM.
- Try to move the visit scheduled for 12PM at the end of the day at 4PM.
- The change is confirmed by pressing enter.
Expected behavior: Visit must move from 12PM to 4PM.
Actual behavior: Visit timing is set back to 12PM.
Cause
The appointment is set back to 12PM as "Automatic Rescheduling" option in route template is enabled.
Resolution
Automatic Rescheduling option, when enabled in route template for visits, always considers the time slot for next visit based on preparation time and duration defined.
Automatic Rescheduling option when disabled in route template for visits, allow users to set the time slot for next visit manually.
Manual slot along with automatic rescheduling, both does not work together. This is current behaviour in the system.
Keywords
Visits, Route template, Automatic Rescheduling, manual, automatic , KBA , LOD-CRM-ACT-VST , Visit Planning , Problem