SAP Knowledge Base Article - Public

3398836 - Change Of Visit's Time In Route Template Not Feasible

Symptom

Time of visit appointment in route template cannot be changed.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Navigate to Visits Work Center.
  2. Go to Routes.
  3. Search and open the Route Template "XXXXXX", where XXXXXX is the route template ID.
  4. Visits in this Route Template for example are scheduled from 8AM to 3PM.
  5. Try to move the visit scheduled for 12PM at the end of the day at 4PM.
  6. The change is confirmed by pressing enter.

Expected behavior: Visit must move from 12PM to 4PM.
Actual behavior: Visit timing is set back to 12PM.

Cause

The appointment is set back to 12PM as "Automatic Rescheduling" option in route template is enabled.

Resolution

Automatic Rescheduling option, when enabled in route template for visits, always considers the time slot for next visit based on preparation time and duration defined.

Automatic Rescheduling option when disabled in route template for visits, allow users to set the time slot for next visit  manually.

Manual slot along with automatic rescheduling, both does not work together. This is current behaviour in the system. 

Keywords

Visits, Route template, Automatic Rescheduling, manual, automatic , KBA , LOD-CRM-ACT-VST , Visit Planning , Problem

Product

SAP Cloud for Customer core applications 2311