Symptom
When creating a time ticket confirmation using API_PROD_ORDER_CONFIRMATION_2_SRV/ProdnOrdConf2 the order is not set to the status CNF (Confirmed), even if you have correctly used the property 'FinalConfirmationType'.
Environment
SAP S/4HANA Cloud.
Reproducing the Issue
- Create a time ticket confirmation using API_PROD_ORDER_CONFIRMATION_2_SRV/ProdnOrdConf2
- Add the property "FinalConfirmationType": "x",
- The order is not set to "CNF"(Confirmed), the operation remains at "PCNF"(Partially Confirmed).
Cause
The value X is case-sensitive.
Resolution
When using the property 'FinalConfirmationType', which is optional, only the following values are possible:
-
blank: Partial confirmation
-
X: Final confirmation
-
1: Automatic final confirmation
The value X is case-sensitive, so please make to use the value in uppercase.
See Also
Keywords
X, API_PROD_ORDER_CONFIRMATION_2_SRV, ProdnOrdConf2, API, uppercase, property, parameter , KBA , PP-SFC-EXE-CON-2CL , Confirmation (Public Cloud) , PP-SFC-ES , Enterprise Services in Shop Floor Control , PP-SFC-ES-2CL , Enterprise Services in Shop Floor Control (Public Cloud) , Problem