SAP Knowledge Base Article - Public

3399410 - Some Card Fields Are Not Editable in Mobile Administration

Symptom

You are configuring the fields that should be visible in the list view, but the edit button is missing for some fields of determined entity (e.g. Opportunity) in mobile administration. 

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental. 

Environment

  • SAP Service Cloud v2
  • SAP Sales Cloud v2

Reproducing the Issue

  1. Click on the profile button.
  2. Select Settings.
  3. Go to All settings.
  4. Navigate to Mobile Administration (Opportunity screen for example).
  5. Go to Opportunity list tab.
  6. Try to edit the field 2 (Expected value) or field 5 (Sales Phase).
  7. You will notice both fields are not editable.
  8. Note: This behavior can happen with other entities in mobile admin (e.g. Lead, Account, Contact and Sales Quote). The field number which are non-editable will also vary.

Cause

By default, the application sets some fields as mandatory to be displayed in the mobile list view.

Resolution

This is currently system behavior. Check the documentation in See Also section to understand which fields are editable or not.

See Also

Help Documentation: Configure the Mobile Application

Keywords

Mobile Administration, List, Editable, Card field, Edit , KBA , CEC-CRM-MOB-ADM , Mobile Administration for SAP Sales/Service Cloud , How To

Product

SAP Sales Cloud and SAP Service Cloud Version 2 1.0

Attachments

ListMobile.png