Symptom
- While querying Background data using OData API you encounter following error due to wrong picklist value "NA".
ERROR: com.sap.gateway.Suite.ip.component.odata.exception.OsciException: Internal Server Error : 500 : HTTP/1.1 - When you create a custom picklist in background element, you will see picklist value "NA" for some of the records.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
- SAP SuccessFactors HCM Suite
- ODATA API
Reproducing the Issue
- Create a new custom picklist field in background element.
- You can see value "NA" for some records through integration center/odata api/EC for that picklist.
- Due to this invalid picklist value, when you query background element, it will through below error:
ERROR: com.sap.gateway.Suite.ip.component.odata.exception.OsciException: Internal Server Error : 500 : HTTP/1.1.
Cause
When you enable or create a new picklist in background element, for old background records, it will assign value NA and for new records it will be null (bank) as shown in above image.
If you observer above image, records with value "NA" are created before the creation/ enable of picklist. Therefore, they have value NA.
Value with null/blank records, are created after the creation /enable of picklist.
Resolution
Here you've to change the value from NA to null/blank through manually or employee import or odata api.
Once all the records with picklist value "NA" gets cleared, you will not receive error 500 anymore.
See Also
Keywords
COE0019, JAVA.MATH.BIGDECIMAL, 11216, 500, Background_*, Background_Education, OData, Picklist, Option ID, text, database, NA, null com.sap.gateway.Suite.ip.component.odata.exception.OsciException: : 500 : HTTP/1.1 , KBA , LOD-SF-INT-ODATA , OData API Framework , Problem