SAP Knowledge Base Article - Public

3401056 - Failed to load metadata in Manage KPIs and Reports | S/4HANA Cloud

Symptom

You are getting "Failed to load metadata" error when opening KPI in Manage KPIs and Reports app.

Environment

SAP S/4HANA Cloud

Reproducing the Issue

  1. Open Manage KPIs and Reports app
  2. Open any KPI
  3. Error message will be triggered

Cause

The KPI application is not published to any catalog in the Custom Catalog Extension. 
(Switch to KPIs tab in main list page -> Click on the application count for KPI -> Navigate to the details of the Blank tile in the Application popover -> Click on the link showing ID YY1_XXXX_SSB -> No catalogs are displayed in the Custom Catalog Extension) 


Resolution

Custom analytical queries need to be published to an application and transported from source system to target system in order for the metadata to be available. 

Therefore, please check if the application has already been published to a catalog in the source system through the Custom Catalog Extension app.

Once published, open Export Software collection application and click on "add items" in your Software collection and search for the App ID (YY1_XXX_SSB), the list of 'Custom Catalog Extension' type objects for all the catalogs where this particular Application has been published will be displayed. Add these items to your software collection and export. When the new additions have been imported into the test system, the metadata failure error would get resolved. 

Keywords

manage KPIs and reports, KPI, report, failure, failed to load metadata, cannot open, not available , KBA , CA-GTF-SB-S4H-DT , SAP Smart Business S4H - Design Time , Problem

Product

SAP S/4HANA Cloud Public Edition all versions