Symptom
You are trying to assign Sales Order as reference at item level of Customer Return.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Sales Orders work center.
- Go to the Returns view.
- Show All Returns and Find XYZ (XYZ represents the ID of the return).
- Go to the Items tab and select the Assign Reference button.
- You assign reference Sales Order ABC(ABC is id of the sales order).
- You get an error message: Sales Order reference with ABC-XX not valid(ABC is the id of the sales order and XX is the line number of the product which you have as assigned reference).
Cause
The delivery status of line item XX in Sales Order ABC is not Finished and is still In Process. Hence the reference is not valid as the item is not yet completely delivered.
Resolution
This is standard system behavior.
If the delivery status of line item in sales order is still In Process then the reference line item of sales order needs to be delivered and status to be set as Finished. Once it is achieved, try and Assign Reference at Item level in Customer Return XYZ.
See Also
KBA 1913167 - The Function Assign Reference for Returns on Item Level Does not Work as Expected
KBA 2894762 - Customer Return is Inconsistent - Sales Order Reference Not Valid
Keywords
Customer Return; Assign Reference; Sales Order; Item; Error Message; Sales Order Reference with ID not valid; Inconsistent. , KBA , AP-CRP , Customer Return Processing , Problem