SAP Knowledge Base Article - Public

3401645 - All dynamic attachments are not sent via email

Symptom

  • All dynamic attachments are not sent via the email. 
  • As per the business rule configured under "Add Dynamic Documents as Email Attachments" scenario, multiple attachments should be sent via email but only one attachment is sent. 

Environment

SAP SuccessFactors Onboarding

Reproducing the Issue

 

  1. Create a new onboardee via Add New Recruit To Onboarding. 
  2. Complete all steps and sign the documents.
  3. See the email does not contain all necessary attachments.

Cause

  • The business rule configured to attach the dynamic attachments is incorrect. 
  • The document template Id used in the business rule does not match with the document template Id generated for the candidate and signed by the user. 

Resolution

  1. Go to Manage Data -> Process. Use the process id of the candidate to get the user record.
  2. Under toFormData section click on detail corresponding to the forms that were not attached
  3. In the Document Template ID there is a small card, click on it and get the template Id. Validate if the same Id is used in the business rule.
  4. If not, please modify the business rule. 

Keywords

Dynamic, attachments, onboarding, email, signed, documents, attachments, not, sent, All, signed, documents.  , KBA , LOD-SF-OBX-EML , Notifications , Problem

Product

SAP SuccessFactors Onboarding all versions