Symptom
When attempting to create a visibility rule through POST /api/v1/quote/visibility, Quote Status field is not being populated in CPQ, even though call is completed successfully.
Environment
SAP Sales Cloud CPQ
Reproducing the Issue
- Perform a POST /api/v1/quote/visibility;
- On advanced condition pass the following snippet:
- "advancedConditions": [ { "leftObjectType": "Quote", "leftObjectTypeSelection": "", "leftProperty": "Quote.Status", "leftCustomFieldProperty": "","operator": "eq", "conditionSelection": "SingleSelect", "rightObjectType": null,"rightObjectTypeSelection": "", "rightProperty": null, "rightCustomFieldProperty": "", "value": "Approved" }]
- Check on Setup -> Quotes -> Quote Visibility Rule that the value of Quote Status is empty.
Cause
In payload being sent on the API Call, "value" is being filled with Quote Status Name.
Resolution
It should be passed Quote Status ID in the advanced condition in order for it to be properly populated in the Visibility Rule:
"advancedConditions": [ { "leftObjectType": "Quote", "leftObjectTypeSelection": "", "leftProperty": "Quote.Status", "leftCustomFieldProperty": "","operator": "eq", "conditionSelection": "SingleSelect", "rightObjectType": null,"rightObjectTypeSelection": "", "rightProperty": null, "rightCustomFieldProperty": "", "value": "<QuoteStatusID>" }]
See Also
Keywords
Quote Visibility, Quote 2.0, API, POST, CPQ , KBA , CEC-SAL-CPQ , Sales Cloud CPQ , Problem