SAP Knowledge Base Article - Public

3401754 - The latest PO/PR workflow instance is not visible

Symptom

If more than one workflow instances are created for PO/PR, the latest workflow instance is not visible.  

This issue affects the creation/maintain/display PO/PR Advanced apps. Examples:

  • "Display Purchase Order - Advanced" (Flexible workflow tab -> Approval Steps) 
  • "Display and Maintain Purchase Requisition - Advanced" (Approval Details). 

Environment

  • SAP S/4HANA Cloud
  • SAP Business Workflow

Reproducing the Issue

Start PO/PR workflows and then check the workflow Approval Details/Steps.

Cause

This is a known issue and will be fixed with Hotfix 512220 (2023).

Resolution

Hotfix 512220 (2023) has been provided for the issue. The Hotfix will be released with Hotfix Collection 10 for release 2308 and it will be deployed to customer systems starting on 07.Dec.2023.

Keywords

WF_GDPR, SWF_WORKFLOW, ME21N, ME23N, ME51N, ME53N , KBA , BC-BMT-WFM , Business Workflow , MM-FIO-PUR-REL , Fiori UI for Purchasing Approval , MM-FIO-PUR-PO-WFL , Purchase Order Workflow , Known Error

Product

SAP S/4HANA Cloud all versions