Symptom
- In the Case Auto Conversion monitor we see the following:
- Status = reprocess
- Exception Message = status provided is invalid. Provide a valid status.
Environment
SAP Sales Cloud and SAP Service Cloud Version 2 1.0
Reproducing the Issue
- Go to Settings
- Case Auto Conversion
- Select the case and "Reprocess"
- The system throws the Exception Message "status provided is invalid. Provide a valid status"
Cause
- Upon inspection of the case, it is evident that the status field is empty
- Customer removed a status from the status schema
- The removed status was previously used in Case XXX
- As a result, the Case data became inconsistent
- Emails sent to the system were attempting to be threaded with the same case
- The expected threading logic failed due to the case being in error with an invalid status
Resolution
- Navigate to the affected case.
- Check if the status field is empty.
- If empty, manually update the status.
- Save the changes.
- Retest
Keywords
KBA , CEC-CRM-CAS , Case Management for SAP Sales/Service Cloud , Problem
Product
SAP Sales Cloud and SAP Service Cloud Version 2 1.0