SAP Knowledge Base Article - Public

3402623 - Email Case Conversion Disrupted by Case Status Schema Change - Invalid Status Provided, Requires a Valid Status

Symptom

  • In the Case Auto Conversion monitor we see the following:
    • Status = reprocess
    • Exception Message = status provided is invalid. Provide a valid status.

Environment

SAP Sales Cloud and SAP Service Cloud Version 2 1.0

Reproducing the Issue

  1. Go to Settings
  2. Case Auto Conversion
  3. Select the case and "Reprocess"
  4. The system throws the Exception Message "status provided is invalid. Provide a valid status"

Cause

  • Upon inspection of the case, it is evident that the status field is empty
  • Customer removed a status from the status schema
  • The removed status was previously used in Case XXX
  • As a result, the Case data became inconsistent
  • Emails sent to the system were attempting to be threaded with the same case
  • The expected threading logic failed due to the case being in error with an invalid status

Resolution

  1. Navigate to the affected case.
  2. Check if the status field is empty.
  3. If empty, manually update the status.
  4. Save the changes.
  5. Retest

Keywords

KBA , CEC-CRM-CAS , Case Management for SAP Sales/Service Cloud , Problem

Product

SAP Sales Cloud and SAP Service Cloud Version 2 1.0