Symptom
Error while importing "Data file does not follow CSV specification. Contact system admin."
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to 'Data Workbench' WC.
- Select 'Import' View.
- Select 'Individual object'.
- Choose 'Insert' -> 'Standard'.
- And then click on 'Service Request Notes'.
Cause
This is because there is an invalid character in the manifest.csv file.
Resolution
Check for comma( ‚ ) or any other invalid character present in the fields Attachment Name and File path in manifest.csv file and then remove or replace it with an alphabet
Upload the file again once the special characters are removed. Notice that there are various special characters like: "\", "/", ":", "*", ", "<", ">", "|", ".", """, "$","[", "]" that should be revisited.
In order to be assertive while correcting, collect the correct template and tested it further.
After treating your original data, specially in relation to ": " records, no errors should be thrown any longer. Example of adjustment:
"From Smoke, Eddie test@test.com
Sent Monday, June 10, 2023 10:50 PM
To SAP Support"
- Please make this corrections before proceeding with further imports in order to avoid such erroneous scenarios.
- Remember to always past data without data format in the template file.
Basically this work of removing special characters aims to exclude polluted format in your file.
See Also
3153204 - Formatting Not Correct Of Generated CSV Errors File In Data Workbench
2725935 - Special Characters in Account Attachments Manifest
Keywords
Error; importing; CSV; specification; contact; system; admin; invalid; character; manifest.csv; template; treating; special. , KBA , LOD-CRM-INT-DWB , Data Workbench , Problem