Symptom
When creating a default value of a UI rule using the code of the field, it returns an unexpected value.
Environment
SAP Cloud for Customer
Reproducing the Issue
This scenario can happen in any object, we will use the Ticket object as an example
- Go to Service work center.
- Go to ticket view.
- Click on Create Ticket button.
- You will see that in the field that was applied the rule of default value, return an unexpected value. For example: return value with 492 code when it should return 49.
Cause
It is a system behavior that if two codes starts with the same numbers, the code with last number will be returned,
for example (you want to return 49, but it exists another code 492, so it will return 492 because in the system the search uses 49* so it will return with last digit together).
Resolution
This is the expected system behavior.
We are constantly thriving to improve our system and hearing your suggestions is the best way forward. Our product managers regularly check the Influence page to hear what changes users would like to see in place and check those for feasibility.
Idea requests can also be voted for by other customers.
If you would like to suggest a change to this behavior, please add this on the Influence page.
Please note that it is not possible for our Support Team to provide you additional information regarding the availability of this feature in a future release.
Keywords
UI rule, unexpected value, default value, error , KBA , AP-RC-UIF-FLX , Page Layout & Key User Configuration , How To