SAP Knowledge Base Article - Public

3404213 - Customer Information not being updated on Quote

Symptom

When updating the global customer with new data, the customer on the quote is not being updated.

Environment

SAP Sales Cloud CPQ

Reproducing the Issue

  1. Update Global Customer Information in Setup;
  2. Try to push updated customer in a quote;
  3. See that values are not being updated.

Cause

This issue appears because there are duplicated records for all customer custom fields for this particular customer.
To fix this, it is necessary to delete all entries and then it should be re-populated manually on admin page or via API.

Resolution

Engage CPQ Support Team informing which customer is giving the error with an approval to run query to delete all custom fields that mention the customer.

Keywords

Global Customer, Customer, Update, Duplicated, CPQ , KBA , CEC-SAL-CPQ , Sales Cloud CPQ , Known Error

Product

SAP CPQ 2023