Symptom
Error when trying to depersonalize an employee: Data depersonalization failed for {employee id}: Retention incomplete.
Environment
- SAP Service Cloud v2
- SAP Sales Cloud v2
Reproducing the Issue
- Click on the profile icon.
- Select Settings.
- Go to All settings.
- Open Data Depersonalization screen.
- Select the affected employee.
- Click on depersonalize button.
- In the pop-up click yes.
- Result: Data depersonalization failed for {employee id}: Retention incomplete.
Cause
In the depersonalization process, the retention check happens only based upon the year, so if retention period is set to 0, and the "Valid To" date of the employee is in the year 2023, then the employee can only pass the retention period check if the current year has passed the valid to year, i.e. in the year 2024, the employee can be depersonalized.
Resolution
This is currently system behavior.
See Also
Help documentation: Data Retention
Keywords
Depersonalization, Employee, Retention, Valid to , KBA , CEC-CRM-DPP , Data Protection and Privacy for SAP Sales/Service Cloud , How To