Symptom
You find the access restriction is not only determined based on Service Execution Team, system also checks other roles.
For sample, a user has restricted to only unit XYZ for Service Order Processing work center view. However, this user can still access to the service orders where Service Execution Team is a not-assigned unit but sales unit filled as XYZ.
(XYZ represents the org unit ID.)
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Service Orders work center.
- Go to the Service Order Processing view.
- Open the service order, in Involved Parties tab, Service Execution Team is ABC, Sales Unit is XYZ.
(ABC, XYZ represents the org unit ID)
Cause
In service order, there are 3 organization units relevant for service planning and dispatching.
- Service Execution Team
- Service and Support Team
- Sales Unit and respective Sales Organization
Access Restriction of the service orders checks all above party roles in the service order, if any of them matches the restriction, then the order is accessible.
Resolution
This is the correct system designed behavior.
Keywords
service order; access restriction; service execution team; service and support team; sales unit , KBA , SRD-CRM-SEO , Service Orders , Problem
SAP Knowledge Base Article - Public