Symptom
The user is trying to make the fields Contact, Priority and Category to visible in Activities with Account Restrictions via Adaptation mode and when they select field and save, the checkbox is restored to unselected.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to Account Management workcenter
- Go to Activities with Account Restriction
- Navigate to User Icon
- Go to Key User Settings
- Select Start Adaptation Mode
- Extend Activities
- Make the field Contact, Priority and Category to Visible
- Select Save
- Publish
Notice the changes are unsaved/unchecked.
Cause
Activities with Account Restriction view does not allow the personalization or adaption for the UI element fields (Contact, Priority & Category).
Resolution
This is the standard system behavior.
Keywords
Contact, Priority, Category, Adaptation Mode, Personalization Mode, Activities with Account Restriction , KBA , AP-RC-UIF-RT-B , ByD HTML5 Client (not for Cloud for Customer) , Problem