Symptom
You are replicating customers from S4H to Sales Cloud V2 but you have experienced an issue about postal code checks.
For one or more countries, you are getting the following error: Postal code XYZ must not have any gaps"; You can not find a way to resolve this in company settings.
In addition, the descriptions of the Rules is not shown and you don't know which Code value should be used.
Reproducing the Issue
- Go to Setttings
- Go to Message Monitoring
- Search for the erroneous messages of entity sap.crm.md.integrationmetadataservice.entity.businessPartnerS4ReplicationMessageIn
Error message details:
"code": "500",
"message": "{\"error\":{\"message\":\"Postal code XYZ must not have any gaps.\",\"code\":\"sap.crm.md.service.addressService.addressMessage.postalCodeNoGapsAllowed\"}}"
Cause
Postal Code Check Rule prevents the respective Postal Code gets processed
In regards to missing Description in the view for the Postal Code Check Rule code values, it has been taken as enhancement and it will be deployed in the upcoming new patches.
Resolution
Refer to the following Code Values to set the one which matches your Postal Code pattern value used in the target system:
0 - Deactivate Postal Code for USA
1 - Maximum value length, without gaps
2 - Maximum value length, numerical, without gaps
3- Length to be kept to exactly, without gaps
4- Length to be kept to exactly, numerical, without gaps
5- Maximum value length
6- Maximum value length, numerical
7- Length to be kept to exactly
8- Length to be kept to exactly, numerical
9- Check against country-specific edit format
See Also
Please note, there is no possibility to let it without any code value validation.
Keywords
KBA , CEC-CRM-INT , Integration for SAP Sales/Service Cloud , Product Enhancement