SAP Knowledge Base Article - Public

3404913 - Unable to click on anything in Legacy Executive Review Find User - Advanced Search

Symptom

In Legacy filters for Executive Review, clicking the First Name field results in a "No Result" and the field is no longer editable

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SuccessFactors HXM Cloud

SuccessFactors Compensation Management

Reproducing the Issue

  1. Go to Compensation > Executive Review
  2. Select template
  3. Click Filter Options
  4. Individual View > Find User
  5. Click on any field - immediately returns "No Result." All search fields will no longer accept entries
  6. Behavior not present when Advanced Executive Review Filters are enabled in Actions for All Plans > Company Settings

Cause

This is a known issue in 2H 2023 caused by a common component applied by the Horizon visual theme.

Resolution

Issue is being actively investigated; as  a workaround, please enable the new Advanced Executive Review filters by following these steps:

  1. go to Compensation Home > Actions for All Plans
  2. click on Company Settings
  3. check Enable advanced executive review filters
  4. click Save

We will update this article once a fix is developed.

Keywords

KBA , LOD-SF-CMP-EXR , Executive Review , Problem

Product

SAP SuccessFactors HXM Core 2311