Symptom
When using the Custom Status field (Standard) or standard status via action, you cannot see all values from the dropdown.
Environment
SAP Cloud for Customer.
Reproducing the Issue
- Open the Opportunity ABC (ABC stand for the Opportunity ID)
- Look for the field Custom Status, or Standard status via Action
- If opportunities exiting values of any out of provides five standard life cycle statuses
Open
In Process
Won or Lost
Stopped - Click on customer status dropdown field or Action to change the standard status
- Not all values are present.
Cause
The solution provides five standard life cycle statuses (Open, In Process, Won or Lost, Stopped) to use as standard or set custom status.
Custom status field value or standard status action options reflects based on opportunity current status. Please refer the below Resolution section for system designed behavior.
Resolution
This is the system designed bahaviour of SAP Cloud for Customer.
Not all Custom status field value or standard status action options reflects but status reflects based on opportunity current status as explained below:
If opportunity status,
- Open - Then only In Process, Won, and Lost will be available, not Stopped
- In Process - Then all values present Open, Won, Lost, and Stopped
- Won or Lost - Only In Process
- Stopped - In Process, Won, and Lost
See Also
Keywords
Custom Status, Opportunity Status, Open Status, In Process Status , KBA , LOD-CRM-OPP , Opportunity Management , Problem