Symptom
Workflow is not working all times, when condition is based on "Created On" and "Reported On" fields
Environment
- SAP Cloud for Customer
- SAP Service Cloud
- SAP Sales Cloud
Reproducing the Issue
- Create a Workflow rule which contains at least one condition:
Created On Equal to Reported On
Cause
Timestamps for "Created On" and "Reported On" fields are displayed with hour and minute format HH:MM
Resolution
- Workflow rule is checking "Created On" and "Reported On" timestamps precisely up to seconds HH:MM:SS
- They get a different data depending on the date/time the back-end system processed the ticket being received in the system when compared to it's actual creation of the object instance.
- Check "See Also" section
See Also
0003217314 - Reported On Field Displays a Different Date from the Created On Field in Service Ticket
Keywords
random "Reported on" "Created On" workflow rule , KBA , LOD-CRM-WKF , Workflow , LOD-CRM-SRP , Service Request Processing , Problem
Product
SAP Cloud for Customer core applications 2311