Symptom
After changing the Item Description in a Contact document, you notice that the changes performed in the Item description were not carried out to the Schedule Invoice Requests.
For example, the Item Description in the Contract document was updated from "XXX" to "ZZZ", however in the Schedule Invoice Requests the Item Description is displayed as "XXX".
Environment
Reproducing the Issue
- Go to the Customer Invoicing work center.
- Go to the Invoice Request view.
- Select the Advanced Search Icon.
- In the Document ID field, Enter the ID ABC (ABC represents the Contract ID).
- In the Document Type, select Contract.
- Mark the Customer Invoice Requests and Schedule Invoice Requests.
The Description maintained in the Customer Invoice Requests and Schedule Invoice Requests are different from the ones maintained in the Contract Document.
Cause
The description of the Items in the Schedule Invoice Request are based on the Item Description of the Customer Contract Invoice Request.
As the changes performed in the Contract document were not carried out to the Customer Contract Invoice Request, the Schedule Invoice Request were generated with the previous Item Description.
Resolution
In this case a dummy change in the Contract ABC will be required in order to update the Item Description of the Customer Contract Invoice Request and Schedule Invoice Requests.
For this process, it will be required to perform the following steps:
- Go to the Sales Order Work Center.
- Go to the Contracts View.
- Filter for All Contracts.
- In the search field, search for the Contract ID ABC.
- Open and select View All.
- Navigate to General tab.
- Perform a change in the Internal Note.
- Select Save button.
- Remove the change performed in the Internal Note.
- Select Save button.
After this changes are performed, the Item Description displayed in the Customer Contract Invoice Request ABC should be updated with current one maintained in the Contract document.
Therefore the Item Description in the Schedule Invoice Requests with status as "To be invoiced" should be updated as well.
Note: If the Schedule Invoice Requests are with status as "Processed" the Item Description will not be updated. The update in the Item Description will only be applied for Schedule Invoice Request with status as 'To be Invoiced".
Keywords
item description, description, contract, schedule invoice request, invoice request, change, update , KBA , SRD-CRM-INV , Customer Invoicing , How To