SAP Knowledge Base Article - Public

3407109 - Unable to Map Talent Intelligence Hub Skills or Competencies to a Job Role

Symptom

After creating competencies or skills using Talent Intelligence Hub, competencies and skills cannot be mapped to job roles in Job Profile Content.

Environment

  • SAP SuccessFactors Talent Intelligence Hub
  • SAP Successfactors Job Profile Builder

Reproducing the Issue

  1. Log in to system
  2. Navigate to Admin Center > Manage Job Profile Content
  3. In the dropdown, select Set Up Families and Roles
  4. Select the Roles tab > Select any role
  5. Select the Mapped Competencies tab > Map Competencies
  6. Select competencies created in TIH > Map > I'm Done > Save Role
  7. Mapped competencies are not displayed

OR

  1. Log in to system
  2. Navigate to Admin Center > Manage Job Profile Content
  3. In the dropdown, select Set Up Families and Roles
  4. Select the Roles tab > Select any role
  5. Select the Mapped Skills tab > Map Skills
  6. Select skills created in TIH > Map > I'm Done > Save Role
  7. Mapped skills are not displayed

Cause

  • Known issue for 2311 where a table was missed in the database
  • Competency data is populated in the en_DEBUG locale
  • The JDM > TIH migration was completed and JPB was enabled afterward

Resolution

Known issue for 2311 where a table was missed in the database

This was fixed in patch MS2311p2 which was on November 30, 2023. If the issue remains after the patch, the competencies or skills need to be recreated:

  • For competencies, change anything in the description and save. This will sync back to JPB and resolve the issue.
  • For skills, make the existing one inactive and recreate the skills that aren't mapped. This will sync back to JPB and resolve the issue.
    1. Log in to system
    2. Navigate to Admin Center > Manage Talent Intelligence Hub
    3. Select the Attributes tab
    4. Locate the Created Date field and click on the calendar icon
    5. Select October 13, 2023 through November 30, 2023 > Go
    6. In the header bar, click the checkbox to select all the attributes > Select Change Status
    7. Select Inactive > Change
    8. Recreate each of the attributes

Competency data is populated in the en_DEBUG locale

en_DEBUG (English (DEBUG)) is currently not supported in Talent Intelligence Hub. The solution is slightly different depending on if you're using data from the en_DEBUG locale.

  • If you are not using data from the en_DEBUG locale, the locale data needs to be removed:
    1. Log in to system
    2. Navigate to Admin Center > Manage Talent Intelligence Hub
    3. Select the Attributes tab
    4. Search for the attribute with the competency type > select the competency
    5. Select Edit
    6. Select the globe icon in the upper right-hand corner to open translations
    7. Select English (DEBUG) > remove all text from the name and description fields > Save
  • If you are using data from the en_DEBUG locale, copy the data from en_DEBUG to a different locale and remove the data from en_DEBUG:
    1. Log in to system
    2. Navigate to Admin Center > Manage Talent Intelligence Hub
    3. Select the Attributes tab
    4. Search for the attribute with the competency type > select the competency
    5. Select Edit
    6. Select the globe icon in the upper right-hand corner to open translations
    7. Select English (DEBUG) > copy all text from the name and description fields
    8. Select a different locale and paste text from the name and description fields > Save

The JDM > TIH migration was completed and JPB was enabled afterward

NOTE: Customers who migrated from JPB > TIH are not impacted by this scenario since they must complete the JDM > JPB migration and correct all check tool errors anyway. Customers who migrate from JDM > TIH are not required to enable JPB.

Whenever the JDM > TIH migration is completed, the system will sync all TIH data to JDM. However, if JPB is enabled after this migration was already completed, the system will now look to JPB to sync data but the JDM > JPB migration hasn't been completed to resolve data issues.

If JPB was enabled after the JDM > TIH migration, all check tool errors from JDM will need to be corrected. Then the JDM > JPB migration will need to be completed for the system to work correctly. Please follow the steps in 2276692 - Best Practices on Job Description Manager to Job Profile Builder Migration.

Competency/Skill object being secured in the system

After TIH upgrade there is no need to keep the security settings for the competency object, as in TIH attribute permissions are applied per the guide Permissions Required for Using Talent Intelligence Hub. Please change the setting for Secured field to "No" following the next steps:

  1. Go to Admin Center > Configure Object Definitions.
  2. Go to Search > Object > Definition  Competency/Skill
  3. Take Action > Make Correction.
  4. Go to the Security section and change the the Secured field dropdown to be No.
  5. Save your changes.

Competency object has capabilityGroup set as required 3700869 - Talent Intelligence Hub: newly created competency can't be mapped to a Job Role or Job Profile - SAP for Me:

  1. Navigate to Configure Object Definitions.
  2. Select Object Definition -> Competency (CompetencyEntity).
  3. Under fields, select capabilityGroup.
  4. Go to Details and set Required field to No.

Keywords

TIH, Talent Intelligence Hub, attributes, competencies, skills, map, add, job role, role, unable to map competencies, unable to map skills, secured object, configure object definition, permissions, not secured, WSM-24077, WSM-24042, PTCH-42655   , KBA , LOD-SF-TIH-SKL , AI Assisted Skills , LOD-SF-TIH-JPB-ADM , Admin Center, Settings, Permissions , LOD-SF-TIH-LIB , Attribute Library , How To

Product

SAP SuccessFactors HXM Suite 2311