Symptom
- Case Management Access Restrictions not working as expected.
- When an internal department linked to the park is filled in, the case is displayed in the list of cases for the designated manager.
- If the service and support team are left empty when "Company YYZ" is filled in a case, the case won't be displayed in the list for the designated manager, illustrating the situation.
Environment
SAP Sales Cloud and SAP Service Cloud Version 2 1.0
Reproducing the Issue
- From Service Cloud or Sales Cloud, navigate to Settings -> Organizational Structure -> Search for and Open "Company YYZ."
- In the Functions tab, enable "Company" and "Service Organization."
- In the Employees tab, locate the manager "Manager 1 YYZ" assigned to the business role "YYZ Manager."
- Apply access restrictions "My employee" and "Org Unit of Employee" on the case service for the "YYZ Manager" business role.
- Open a case, for example, Case ID 123ABC, with the company name filled as "Company YYZ" and an empty service team.
Cause
- System is working as designed
- The Case access restriction operates based on the context of the service team and employees involved in the case.
- The Company attribute does not participate in access restrictions.
- Cases with an empty service team are not visible to the designated manager due to this configuration.
Resolution
To address this issue:
- Recognize that Case access restrictions work on the context of the service team and employees involved.
- Note that the Company attribute does not impact access restrictions.
- Ensure that the access restriction rules (Role - case service - restriction rule) are appropriately configured based on Employee / Org unit (Service org / Service / Sales org).
See Also
Case Management Access control
Keywords
ACL, Access Control, Service Cloud V2 , KBA , CEC-CRM-CAS , Case Management for SAP Sales/Service Cloud , Problem
Product
SAP Sales Cloud and SAP Service Cloud Version 2 1.0