Symptom
You have created a service ticket in C4C system, while requesting the external pricing you got the following error messages.
- Price Component missing.
- Price Procedure code is missing.
- Pricing data could not be read.
- Sales document was not changed.
- Ship to Party is not assigned.
Environment
SAP Cloud for Customer
Reproducing the Issue
-
Go to the Service work center.
- Go to the view Work Tickets.
- Open the respective ticket and press the button Request External Pricing under the Actions.
- You will get the above error messages.
Cause
Issue is caused because you have maintained duplicate ID mappings of ERP Sales Organisation & ERP Account.
-
ID Mapping of ERP Sales Organisation is maintained in ERP Planning Group also.
- ID Mapping of ERP Accounts maintained in Business Partner as well as External Business Partner objects.
Resolution
- Go to the Administration Work Center.
- Open the ID Mapping for Integration.
-
Delete the duplicate ID Mapping from ERP Planning Group.
-
Delete the duplicate ID Mapping from Business Partner as well as from External Business Partner.
Keywords
Request External pricing , Service tickets, Sales document was not changed , KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , Problem
Product
SAP Cloud for Customer core applications all versions