SAP Knowledge Base Article - Public

3408632 - Account Field is Greyed-Out and Cannot be Changed in a Sales Quote or Service Quote

Symptom

In a Sales Quote or Service Quote scenario, after the Account has been maintained and the document saved, you notice that it is no longer possible to remove or change the Account selected.

Environment

SAP Business ByDesign.

Reproducing the Issue

  1. Go to the New Business work center.
  2. Go to the Sales Quotes view.
  3. Search for the Sales Quote ID ABC (Where ABC represents the ID of the Sales Quote).
  4. Click the Edit button.
  5. Click on the View All button.

You notice that there is no option to change/edit the Account maintained. The same is also true for Service Quotes.

Cause

Once an Account has been saved in a Sales Quote or Service Quote, it is no longer possible to make further changes to the Account selected. 

Resolution

This is the expected system behavior. If another Account is needed in the Sales/Service Quote, you need to cancel the erroneously created Quote and then raise a new one with the expected Account.

Keywords

Sales Quote, Service Quote, Account, Unable, Change, Edit, Remove, Impossible, Not Able, Quotation, Editable. , KBA , SRD-CRM-QUO , Quotations , How To

Product

SAP Business ByDesign all versions