Symptom
E-mail is being sent to all Account maintained in the relationship of contact and does not respect the "Main" indicator for a particular account
Environment
SAP Cloud for Customer
Reproducing the Issue
Pre-Requisite: A Workflow Rule is Configured to execute and send E-mail with survey.
Issue is valid for all BO's. Here we will consider the Sales Order BO for demonstration purpose.
- Go to Sales Work Center View
- Go to Sales Order View
- Open Sales Order XYZ ; XYZ represents Sales Order ID for which the Workflow is triggered
- Go to Workflow Changes tab
- See that the Workflow Rule ABC is triggered ; ABC is the name of E-mail Workflow Rule which has the Recipient Determination set as "Account’s Contacts of Sales Order"
- Go to Activities tab and see in the E-mails section the E-mail from Workflow is triggered for all Accounts of the determined Contact even if only one is set as "Main"
Cause
The Address Determination Setting "Use main address of the recipient to send out e-mail and sms" is not selected
Resolution
For the Workflow Rule to respect "Main" indicator while sending the E-mail the Address Determination Setting "Use main address of the recipient to send out e-mail and sms" needs to be selected.
You can follow the below steps to select this setting:
- Go to Administrator Work Center
- Go to Workflow Rules View
- Click on More
- Click on Workflow Settings
- Select the question "Use main address of the recipient to send out e-mail and sms" by clicking on the check-box
- Click on Save
Now the E-mails sent from Workflow Rules will only be sent to the recipient which has the "Main" indicator selected.
Keywords
Sales Order , Main , Workflow Rules , E-mail , Workflow E-mail , Address Determination , Recipient Determination , Account , Contact , KBA , LOD-CRM-WKF , Workflow , How To