SAP Knowledge Base Article - Public

3408819 - E-Verify Case Not Created and Cannot Manually Create for a Candidate - Onboarding

Symptom

  • Everify case did not trigger for a candidate.
  • Internal Error was received when creating an E-Verify case for a candidate manually.

Environment

SAP SuccessFactors Onboarding

Reproducing the Issue

  1. Go to Create E-Verify Case 
  2. Try to create a case
  3. Internal Error received

Cause

  • E-Verify did not trigger due to the type of document selected for list B.
  • Document Type used: Individual under Age 18.

Error Logs:

  • {"error":{"code":"InternalError","message":"Internal error","details":[{"code":"COE0019","message":"Failed to get EVerifyData "
  • EVerifyException: I9 document INDIVIDUAL_UNDER_AGE_18 cannot be mapped to E-Verify document.

Resolution

At present, the system is not designed to block individuals from selecting documents such as:

  • School record or report card
  • Clinic, doctor, or hospital record
  • Daycare or nursery school record

PERMANENT FIX:

The Product Team has created an enhancement to improve the usability and assist the end users better. 

While we work on this enhancement, we suggest that the end users monitor this aspect to avoid selecting the wrong documents. 

WORKAROUND:

  • If an incorrect document was entered, you may use the Trigger I-9 flow to correct the I9 of the affected candidates.

 

Since this is an enhancement, there is currently no committed date on the roadmap, but it is tentatively planned to be deployed on 1H 2024 (b2405). You may have this posted via the Influence Portal to track the progress of the enhancement.

Keywords

OBX-27194, E-Verify Case, Failed to get EVerifyData, Internal Error, Under age 18, List B, Document Type, I-9 Error , KBA , LOD-SF-OBX-EVF , Everify , Product Enhancement

Product

SAP SuccessFactors Onboarding 2311