Symptom
- When launching courses with duration longer than 30 min from Work Zone, session expires and users can't complete the course. As a result, there is no automatic save.
- Error message appears: Failed to extend the session! while doing course
- Popup with failed message says: A communication error has occurred during the server ping to keep the session alive.
Environment
- SAP SuccessFactors Work Zone
- SAP SuccessFactors Learning
Reproducing the Issue
- After logged in Work Zone, access SuccessFactors
- Go to Learning
- Start any course
- Stay in the course for more than 30 min
Click the button to go ahead and wait. The important thing is not to finish the course before 30 min. - When the 30 min has passed and you are still in the course section, no notice appears. And the session expires, without saving any changes
- The error messages appears
Cause
Session timeout in the "design time" (Design Time is what we also call 'Site Manager', with the 'dt' in URL) settings is less than 30 mins.
Resolution
Please make sure to reset this timeout, as per steps below:
- Admin Console
- External Integrations
- Business Content > Content Manager
- After that, under Site Directory, select the "Open settings" gear button
- You will see "Session Timeout"
- Use the edit button on the top right to change the value
Keywords
workzone, training, time out, timeout , KBA , LOD-SF-SWZ-PER , Performance Issues , Problem
Product
SAP SuccessFactors Learning 2311 ; SAP SuccessFactors Work Zone all versions