SAP Knowledge Base Article - Public

3410374 - When logging in with a non-English language, the default date format of DD/MM/YYYY is incorrectly displaying as the English format MM/DD/YYYY

Symptom

  • Problem Encountered in Agent Desktop or Post-Creation of a Phone Call Activity from a Lead
  • Time and Region Settings Discrepancy:
    • The configured time and region settings are not being accurately reflected in the User Interface (UI) as per user expectations.
    • The customer anticipates that the date format in the UI should seamlessly adhere to the designated time and region settings.
  • Inconsistency in Time Intervals:
    • The time intervals presented in the UI do not align with the corresponding intervals set at the operating system (OS) level.
    • Specifically, there is a disparity observed when the Agent Desktop is initially launched, as the displayed time intervals do not match those expected based on the OS configuration.

Environment

  • SAP Service Cloud Version 2 1.0
  • SAP Sales Cloud Version 2 1.0

Reproducing the Issue

  • Agent Desktop:
    1. Logon with a non-English language
    2. Navigate to the Agent Desktop
    3. Locate the Interaction Log within the Agent Desktop interface.
      • Observe the date format displayed in the Interaction Log.
      • Note that the expected format should be DD/MM/YYYY, based on the user's time zone settings .
    4. Additionally, confirm that the time associated with each interaction aligns with the system time at the operating system (OS) level.
    5. Ensure that the displayed time accurately reflects the current time on the initial launch of the Agent Desktop.
  • Lead:
    1. Logon with a non-English language
    2. Go to Leads
    3. Open an existing lead or create a new one
    4. Under the Activity, click on the + to create an activity, then select "Telephone"
      • Notice the date format is displayed as MM/DD/YYYY
      • The expectation if for the date format to be as DD/MM/YYYY and the time to be in a 24 hour format

Cause

3rd party configuration

Resolution

  • To ensure that texts appear consistently in the same logon language, review the following three language settings:
    • Before you log on to the solution, choose the preferred language from the dropdown list.
    • Make sure that the browser locale is correct, the locale is used to determine the date, time zone, or amount formats.
    • In the operating system itself, ensure that the preferred language is defined as the display language.
    • The date/time format displayed in the Agent Desktop UI is based on the browser preferred language
  • Verifying the existing browser language via the Developer tool console
    1. Go to the Agent Desktop
    2. Right click and click on "Inspect" or hit Ctrl+Shift+I (English 101 keyboard)
    3. At the end of the console, enter the following commands:
      • window.auth4crm.AuthUtil.getLocale() [Hit enter] -> the default browser language should be displayed.
      • Intl.DateTimeFormat().format(new Date()) [Hit enter] -> this will show the current date format
  • If you want to use English as the language, but want to still have the same DD/MM/YYYY format with 24 hour time format, then you need to set the preferred browser language as "English (United Kingdom)". For example, in Chrome:
    1. Go to Settings
    2. Search for "Preferred Languages"
    3. Add/Select "English (United Kingdom)" and make it as the default UI language
    4. This language is used to display the Google Chrome UI)
    5. This language should also be at the top if there are other languages in the list
    6. Restart the browser and retest

See Also

Language Settings

Keywords

KBA , CEC-CRM-AD , Agent desktop - live channels , Problem

Product

SAP Sales Cloud and SAP Service Cloud Version 2 1.0