SAP Knowledge Base Article - Preview

3410514 - User Role cannot be updated via User API

Symptom

The functionality to update the user role through the FSM User API is not operating as expected. The following error message is returned:

{
    "error": "CM-06",
    "message": "CM-06: The server cannot or will not process the request due to something that is perceived to be a client error. [Only CUSTOMER, EXTERNAL_SUPERUSER or SUPERUSER may edit user roles!]",
    "values": [
        "Only CUSTOMER, EXTERNAL_SUPERUSER or SUPERUSER may edit user roles!"
    ],
    "id": "fd324bb4ab18401d98702ae3811ebd76"
}


Read more...

Environment

  • SAP Field Service Management

Keywords

KBA , CEC-SRV-FSM-API , FSM API , CEC-SRV-FSM , Field Service Management , How To

About this page

This is a preview of a SAP Knowledge Base Article. Click more to access the full version on SAP for Me (Login required).

Search for additional results

Visit SAP Support Portal's SAP Notes and KBA Search.