Symptom
- While creating or modifying a lead and selecting the 'Phone Call' activity, the start date 'time' field displays inaccurately.
- The time is presented in 24-hour format, and next to it, it incorrectly indicates "AM"/"PM" following the 12-hour format.
Environment
- SAP Service Cloud Version 2.1.0
- SAP Sales Cloud 2.1.0
Reproducing the Issue
- Login in with support user in Dutch language
- Go to Leads
- Open any existing lead- right side under activities
- Click + icon (under Activities) to add the phone call activity
- Select the Phone Call
- ***Issue:- The time shows in 24hr format, but there is AM next to it
- This issue does not happen when logged on in English
Cause
Missing configuration
Resolution
- Go to Settings -> Employee
- Add your Time Zone entry in the Working Day Calendar
- Go to your browser settings -> Language
- Add your Language to the top, as the preferred language
- In the operating system itself, ensure that the preferred language is defined as the display language.
- Exit the Service Cloud, logon and test again
See Also
Keywords
Language, format, preference, DD/MM/YY, DD/MM/YYYY, MM/DD/YY, MM/DD/YYYY, 24 hour, 12 hour, English, German, Dutch, Spanish, Localization , KBA , CEC-CRM-PH , Phone Calls for SAP Sales/Service Cloud , Problem
Product
SAP Sales Cloud and SAP Service Cloud Version 2 1.0