SAP Knowledge Base Article - Public

3410752 - Lead Activity Time Field Displays AM/PM Format Suffix During Phone Call Creation

Symptom

  • While creating or modifying a lead and selecting the 'Phone Call' activity, the start date 'time' field displays inaccurately.
  • The time is presented in 24-hour format, and next to it, it incorrectly indicates "AM"/"PM" following the 12-hour format.

Environment

  • SAP Service Cloud Version 2.1.0
  • SAP Sales Cloud 2.1.0

Reproducing the Issue

  1. Login in with support user in Dutch language
  2. Go to Leads
  3. Open any existing lead- right side under activities
  4. Click + icon (under Activities) to add the phone call activity
  5. Select the Phone Call
  • ***Issue:- The time shows in 24hr format, but there is AM next to it
  • This issue does not happen when logged on in English

 

Cause

Missing configuration

Resolution

  1. Go to Settings -> Employee
  2. Add your Time Zone entry in the Working Day Calendar
  3. Go to your browser settings -> Language
  4. Add your Language to the top, as the preferred language
  5. In the operating system itself, ensure that the preferred language is defined as the display language.
  6. Exit the Service Cloud, logon and test again

See Also

Language Settings

Keywords

Language, format, preference, DD/MM/YY, DD/MM/YYYY, MM/DD/YY, MM/DD/YYYY, 24 hour, 12 hour, English, German, Dutch, Spanish, Localization , KBA , CEC-CRM-PH , Phone Calls for SAP Sales/Service Cloud , Problem

Product

SAP Sales Cloud and SAP Service Cloud Version 2 1.0