SAP Knowledge Base Article - Public

3410805 - Authorization Error when accessing Ticket

Symptom

Some users are unable to access some tickets even though they appear to have the required authorizations.

The error could be: "You are not authorized to access this object. If you want access, ensure that it is added to your role."

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the work center view Tickets.
  2. Search for the required ticket. You will see it in the list.
  3. Open it - now you receive the error.

Cause

The user has access restrictions that are not consistent across the required work center views.

For example, the user has access to a specific org units as per the restriction on the work center view "Tickets". However there are a few more work center views which are relevant to give access to tickets. On one of those, the same user has no access to the same org unit. This creates the inconsistency that the user is able to see the ticket in the list but cannot open it.

 

Resolution

To have consistent access to cases, we would recommend to maintain the same access restrictions across the following work center view IDs:

  • SEOD_TICKETMD_SADL_WCVIEW
  • SEOD_TICKET_SADL_WCVIEW
  • SEOD_QUEUE_SADL_OWL
  • TICKET_DESKTOP_NAVIGATION
  • TICKET_TABLET_NAVIGATION

They are all part of the Tickets work center.

The steps to check and change this setting are:

  1. Go to the work center Administrator, view Business User.
  2. Search for the respective user and click Edit > Access Rights.
  3. Go to the tab Access Restrictions.
  4. Search for the Tickets work center and check each of the mentioned work center view IDs.
  5. In the "Detailed Restrictions" table underneath the work center view list, please ensure that the restrictions are set the same for the mentioned views.

Keywords

You are not authorized to access this object. If you want access, ensure that it is added to your role, tickets, cases, authorization issue, access rights, error message, service , KBA , LOD-CRM-SRP , Service Request Processing , How To

Product

SAP Cloud for Customer core applications 2311